Heap-based Buffer Overflow Affecting gvfs-backend-afc package, versions <1.52.2-150600.3.9.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.45% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-GVFSBACKENDAFC-19908703
  • published18 Sept 2026
  • disclosed17 Sept 2026

Introduced: 17 Sep 2026

CVE-2026-84269  (opens in a new tab)
CWE-122  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 gvfs-backend-afc to version 1.52.2-150600.3.9.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gvfs-backend-afc package and not the gvfs-backend-afc package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

A flaw was found in the AFP backend in gvfs. When mounting a share, a malicious AFP server can cause the DSI read path to process a length that exceeds the size requested by the client. The function does not verify the server-provided length against the pre-sized reply buffer, causing the operation to access past the intended boundaries. This issue allows a malicious server to overflow a heap buffer and crash the gvfsd-afp process, resulting in a denial of service.

CVSS Base Scores

version 3.1