CRLF Injection Affecting gvfs-devel package, versions <1.52.2-150600.3.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.42% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-GVFSDEVEL-15802308
  • published29 Mar 2026
  • disclosed23 Mar 2026

Introduced: 23 Mar 2026

CVE-2026-28296  (opens in a new tab)
CWE-93  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 gvfs-devel to version 1.52.2-150600.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gvfs-devel package and not the gvfs-devel package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

A flaw was found in the FTP GVfs backend. A remote attacker could exploit this input validation vulnerability by supplying specially crafted file paths containing carriage return and line feed (CRLF) sequences. These unsanitized sequences allow the attacker to terminate intended FTP commands and inject arbitrary FTP commands, potentially leading to arbitrary code execution or other severe impacts.

CVSS Base Scores

version 3.1