Uncaught Exception Affecting himmelblau package, versions <2.3.9+git0.a9fd29b-150700.3.15.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.73% (53rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-HIMMELBLAU-16090472
  • published16 Apr 2026
  • disclosed15 Apr 2026

Introduced: 15 Apr 2026

CVE-2024-11738  (opens in a new tab)
CWE-248  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 himmelblau to version 2.3.9+git0.a9fd29b-150700.3.15.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream himmelblau package and not the himmelblau package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

A flaw was found in Rustls 0.23.13 and related APIs. This vulnerability allows denial of service (panic) via a fragmented TLS ClientHello message.

CVSS Base Scores

version 3.1