Use After Free Affecting himmelblau-sshd-config package, versions <0.7.17+git.0.1ebdab0-150700.3.3.2


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.52% (43rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-HIMMELBLAUSSHDCONFIG-10568354
  • published1 Jul 2025
  • disclosed30 Jun 2025

Introduced: 30 Jun 2025

CVE-2025-3416  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 himmelblau-sshd-config to version 0.7.17+git.0.1ebdab0-150700.3.3.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream himmelblau-sshd-config package and not the himmelblau-sshd-config package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

A flaw was found in OpenSSL's handling of the properties argument in certain functions. This vulnerability can allow use-after-free exploitation, which may result in undefined behavior or incorrect property parsing, leading to OpenSSL treating the input as an empty string.

CVSS Base Scores

version 3.1