Heap-based Buffer Overflow Affecting ImageMagick-config-7-upstream-secure package, versions <7.1.1.43-150700.3.33.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.68% (52nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-IMAGEMAGICKCONFIG7UPSTREAMSECURE-15271129
  • published12 Feb 2026
  • disclosed11 Feb 2026

Introduced: 11 Feb 2026

CVE-2026-23876  (opens in a new tab)
CWE-122  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 ImageMagick-config-7-upstream-secure to version 7.1.1.43-150700.3.33.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ImageMagick-config-7-upstream-secure package and not the ImageMagick-config-7-upstream-secure package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 7.1.2-13 and 6.9.13-38, a heap buffer overflow vulnerability in the XBM image decoder (ReadXBMImage) allows an attacker to write controlled data past the allocated heap buffer when processing a maliciously crafted image file. Any operation that reads or identifies an image can trigger the overflow, making it exploitable via common image upload and processing pipelines. Versions 7.1.2-13 and 6.9.13-38 fix the issue.

CVSS Base Scores

version 3.1