Out-of-bounds Read Affecting jq package, versions <1.6-150000.3.20.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.17% (7th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-JQ-17977286
  • published15 Jul 2026
  • disclosed14 Jul 2026

Introduced: 14 Jul 2026

CVE-2026-39956  (opens in a new tab)
CWE-125  (opens in a new tab)
CWE-476  (opens in a new tab)
CWE-843  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 jq to version 1.6-150000.3.20.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream jq package and not the jq package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

jq is a command-line JSON processor. Prior to version 1.8.2, the _strindices builtin in jq's src/builtin.c passes its arguments directly to jv_string_indexes() without verifying they are strings, and jv_string_indexes() in src/jv.c relies solely on assert() checks that are stripped in release builds compiled with -DNDEBUG. This allows an attacker to crash jq trivially with input like _strindices(0), and by crafting a numeric value whose IEEE-754 bit pattern maps to a chosen pointer, achieve a controlled pointer dereference and limited memory read/probe primitive. Any deployment that evaluates untrusted jq filters against a release build is vulnerable. This issue has been patched in commit fdf8ef0f0810e3d365cdd5160de43db46f57ed03, which is part of version 1.8.2.

CVSS Base Scores

version 3.1