Double Free Affecting libasound2 package, versions <1.2.10-150600.4.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.14% (3rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-LIBASOUND2-18343626
  • published28 Jul 2026
  • disclosed27 Jul 2026

Introduced: 27 Jul 2026

CVE-2026-56109  (opens in a new tab)
CWE-415  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 libasound2 to version 1.2.10-150600.4.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libasound2 package and not the libasound2 package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

The Advanced Linux Sound Architecture (ALSA) library before 1.2.16.1 contains a double-free vulnerability in parse_def() in src/conf.c that allows attackers to corrupt memory by supplying maliciously crafted ALSA configuration text. When parsing nested compound or array configuration blocks, parse_def() fails to check return values before continuing, causing snd_config_delete() to be called twice on the same already-freed node, resulting in a NULL-pointer write or invalid memory read.

CVSS Base Scores

version 3.1