Heap-based Buffer Overflow Affecting libcaca0 package, versions <0.99.beta20-150600.3.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.37% (31st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-LIBCACA0-17353973
  • published17 Jun 2026
  • disclosed16 Jun 2026

Introduced: 16 Jun 2026

CVE-2026-42046  (opens in a new tab)
CWE-122  (opens in a new tab)
CWE-190  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 libcaca0 to version 0.99.beta20-150600.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libcaca0 package and not the libcaca0 package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

libcaca is a colour ASCII art library. In 0.99.beta20 and earlier, an integer overflow vulnerability in libcaca's canvas import functionality allows an attacker to cause a controlled heap out-of-bounds write (heap overflow) by supplying a crafted file in the "caca" format. Depending on the build configuration and memory allocator, this may lead to memory corruption or remote code execution. This is the same vulnerability as CVE-2021-3410 but the fix at that time was not fully correct. Commit fb77acff9ba6bb01d53940da34fb10f20b156a23 fixes this vulnerability.

CVSS Base Scores

version 3.1