CVE-2023-26819 Affecting libcjson1 package, versions <1.7.19-150700.3.3.1


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.23% (14th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-LIBCJSON1-13531888
  • published11 Oct 2025
  • disclosed10 Oct 2025

Introduced: 10 Oct 2025

CVE-2023-26819  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 libcjson1 to version 1.7.19-150700.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libcjson1 package and not the libcjson1 package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

cJSON 1.7.15 might allow a denial of service via a crafted JSON document such as {"a": true, "b": [ null,9999999999999999999999999999999999999999999999912345678901234567]}.

CVSS Base Scores

version 3.1