CVE-2025-57052 Affecting libcjson1 package, versions <1.7.19-150700.3.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.74% (52nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-LIBCJSON1-13531889
  • published11 Oct 2025
  • disclosed10 Oct 2025

Introduced: 10 Oct 2025

CVE-2025-57052  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 libcjson1 to version 1.7.19-150700.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libcjson1 package and not the libcjson1 package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

cJSON 1.5.0 through 1.7.18 allows out-of-bounds access via the decode_array_index_from_pointer function in cJSON_Utils.c, allowing remote attackers to bypass array bounds checking and access restricted data via malformed JSON pointer strings containing alphanumeric characters.

CVSS Base Scores

version 3.1