Improper Validation of Specified Quantity in Input Affecting libidn-devel package, versions <1.34-150000.3.5.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.14% (3rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-LIBIDNDEVEL-19783478
  • published14 Sept 2026
  • disclosed7 Sept 2026

Introduced: 7 Sep 2026

CVE-2026-57053  (opens in a new tab)
CWE-1284  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 libidn-devel to version 1.34-150000.3.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libidn-devel package and not the libidn-devel package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

GNU libidn before 1.44 is prone to out-of-bounds reads of uninitialized memory in the ToUnicode APIs because of mishandling in idna_to_unicode_internal. The affected code is not present in libidn2.

CVSS Base Scores

version 3.1