Use After Free Affecting libjasper4 package, versions <2.0.14-150000.3.37.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.26% (18th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-LIBJASPER4-12704932
  • published16 Sept 2025
  • disclosed15 Sept 2025

Introduced: 15 Sep 2025

CVE-2025-8837  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 libjasper4 to version 2.0.14-150000.3.37.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libjasper4 package and not the libjasper4 package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

A vulnerability was identified in JasPer up to 4.2.5. This affects the function jpc_dec_dump of the file src/libjasper/jpc/jpc_dec.c of the component JPEG2000 File Handler. The manipulation leads to use after free. An attack has to be approached locally. The exploit has been disclosed to the public and may be used. The patch is named 8308060d3fbc1da10353ac8a95c8ea60eba9c25a. It is recommended to apply a patch to fix this issue.

CVSS Base Scores

version 3.1