Out-of-Bounds Affecting libjq-devel package, versions <1.7.1-150000.3.25.1


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
7.27% (95th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-LIBJQDEVEL-20044003
  • published22 Sept 2026
  • disclosed21 Sept 2026

Introduced: 21 Sep 2026

CVE-2015-8863  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 libjq-devel to version 1.7.1-150000.3.25.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libjq-devel package and not the libjq-devel package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

Off-by-one error in the tokenadd function in jv_parse.c in jq allows remote attackers to cause a denial of service (crash) via a long JSON-encoded number, which triggers a heap-based buffer overflow.

CVSS Base Scores

version 3.1