CVE-2026-18238 Affecting libpcap1 package, versions <1.10.5-150700.3.13.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.18% (7th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-LIBPCAP1-19853197
  • published16 Sept 2026
  • disclosed15 Sept 2026

Introduced: 15 Sep 2026

CVE-2026-18238  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 libpcap1 to version 1.10.5-150700.3.13.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpcap1 package and not the libpcap1 package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

The rpcap client code that processes a RPCAP_MSG_PACKET message received from the server incorrectly validates its headers. A malicious server can send a crafted message and cause the client to treat up to 20 bytes of the client process memory beyond the end of the buffer as if it was a part of the captured packet.

CVSS Base Scores

version 3.1