CVE-2026-0994 Affecting libprotobuf20 package, versions <3.9.2-150200.4.30.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.71% (53rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-LIBPROTOBUF20-15343473
  • published25 Feb 2026
  • disclosed24 Feb 2026

Introduced: 24 Feb 2026

CVE-2026-0994  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 libprotobuf20 to version 3.9.2-150200.4.30.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libprotobuf20 package and not the libprotobuf20 package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

A denial-of-service (DoS) vulnerability exists in google.protobuf.json_format.ParseDict() in Python, where the max_recursion_depth limit can be bypassed when parsing nested google.protobuf.Any messages.

Due to missing recursion depth accounting inside the internal Any-handling logic, an attacker can supply deeply nested Any structures that bypass the intended recursion limit, eventually exhausting Python’s recursion stack and causing a RecursionError.

CVSS Base Scores

version 3.1