Out-of-bounds Read Affecting libraw23 package, versions <0.21.1-150600.3.5.1


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.45% (38th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-LIBRAW23-10324003
  • published7 Jun 2025
  • disclosed6 Jun 2025

Introduced: 6 Jun 2025

CVE-2025-43963  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 libraw23 to version 0.21.1-150600.3.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libraw23 package and not the libraw23 package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

In LibRaw before 0.21.4, phase_one_correct in decoders/load_mfbacks.cpp allows out-of-buffer access because split_col and split_row values are not checked in 0x041f tag processing.

CVSS Base Scores

version 3.1