Improper Validation of Specified Quantity in Input Affecting libraw-devel package, versions <0.21.1-150600.3.5.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.42% (36th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-LIBRAWDEVEL-10323997
  • published7 Jun 2025
  • disclosed6 Jun 2025

Introduced: 6 Jun 2025

CVE-2025-43964  (opens in a new tab)
CWE-1284  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 libraw-devel to version 0.21.1-150600.3.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libraw-devel package and not the libraw-devel package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

In LibRaw before 0.21.4, tag 0x412 processing in phase_one_correct in decoders/load_mfbacks.cpp does not enforce minimum w0 and w1 values.

CVSS Base Scores

version 3.1