CVE-2026-6047 Affecting libreoffice-l10n-si package, versions <26.2.5.1-150500.20.37.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.15% (5th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-LIBREOFFICEL10NSI-18167822
  • published22 Jul 2026
  • disclosed20 Jul 2026

Introduced: 20 Jul 2026

CVE-2026-6047  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 libreoffice-l10n-si to version 26.2.5.1-150500.20.37.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libreoffice-l10n-si package and not the libreoffice-l10n-si package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

LibreOffice can import documents in the OOXML format (DOCX). A heap buffer overflow existed when replaying deferred parser events for a text box element. A handler object was assumed to be of one type and written to at that type's field layout, but it could be a smaller object, so the write landed past the end of the allocation. In fixed versions the type is checked before the write.

CVSS Base Scores

version 3.1