Cross-site Request Forgery (CSRF) Affecting librsvg-devel package, versions <2.57.4-150600.3.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.23% (14th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-LIBRSVGDEVEL-15064792
  • published23 Jan 2026
  • disclosed22 Jan 2026

Introduced: 22 Jan 2026

CVE-2024-12224  (opens in a new tab)
CWE-352  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 librsvg-devel to version 2.57.4-150600.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream librsvg-devel package and not the librsvg-devel package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

Improper Validation of Unsafe Equivalence in punycode by the idna crate from Servo rust-url allows an attacker to create a punycode hostname that one part of a system might treat as distinct while another part of that system would treat as equivalent to another hostname.

CVSS Base Scores

version 3.1