CVE-2025-31335 Affecting libsaml11 package, versions <3.1.0-150300.3.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.25% (16th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-LIBSAML11-10304997
  • published6 Jun 2025
  • disclosed5 Jun 2025

Introduced: 5 Jun 2025

CVE-2025-31335  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 libsaml11 to version 3.1.0-150300.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsaml11 package and not the libsaml11 package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

The OpenSAML C++ library before 3.3.1 allows forging of signed SAML messages via parameter manipulation (when using SAML bindings that rely on non-XML signatures).

CVSS Base Scores

version 3.1