CVE-2026-9539 Affecting libslirp-devel package, versions <4.7.0+44-150500.4.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.22% (13th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-LIBSLIRPDEVEL-17977558
  • published15 Jul 2026
  • disclosed13 Jul 2026

Introduced: 13 Jul 2026

CVE-2026-9539  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 libslirp-devel to version 4.7.0+44-150500.4.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libslirp-devel package and not the libslirp-devel package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

An out-of-bounds heap read and integer underflow in the TCP urgent data handling (sosendoob) in freedesktop.org libslirp version before v4.9.2 on hypervisor host environments (e.g., QEMU) allows a privileged guest VM attacker (root or CAP_NET_RAW) to leak gigabytes of sensitive host-process heap memory via sending crafted TCP segments with manipulated URG flags and urgent pointers (ti_urp).

CVSS Base Scores

version 3.1