CVE-2025-70873 Affecting libsqlite3-0 package, versions <3.51.3-150000.3.39.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.46% (40th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-LIBSQLITE30-15853141
  • published31 Mar 2026
  • disclosed26 Mar 2026

Introduced: 26 Mar 2026

CVE-2025-70873  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 libsqlite3-0 to version 3.51.3-150000.3.39.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsqlite3-0 package and not the libsqlite3-0 package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

An information disclosure issue in the zipfileInflate function in the zipfile extension in SQLite v3.51.1 and earlier allows attackers to obtain heap memory via supplying a crafted ZIP file.

CVSS Base Scores

version 3.1