Use After Free Affecting libtexluajit2 package, versions <2.1.0beta3-150600.38.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.18% (7th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-LIBTEXLUAJIT2-18915777
  • published18 Aug 2026
  • disclosed17 Aug 2026

Introduced: 17 Aug 2026

CVE-2026-63729  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 libtexluajit2 to version 2.1.0beta3-150600.38.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libtexluajit2 package and not the libtexluajit2 package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

The SyncTeX parser (synctex_parser.c) shipped with TeX Live and embedded by downstream consumers such as GNOME Evince contains a heap use-after-free vulnerability that allows attackers to crash applications or potentially execute arbitrary code by supplying a malformed .synctex or .synctex.gz file. A malformed SyncTeX file can construct a ref node with a NULL parent pointer, causing the replacement routine to fail to detach the node from its sibling chain, which triggers recursive freeing of live tree nodes and leaves dangling pointers that are later accessed by the parser during document load.

CVSS Base Scores

version 3.1