Heap-based Buffer Overflow Affecting libtiff5 package, versions <4.0.9-150000.45.72.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.12% (2nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-LIBTIFF5-21463383
  • published23 Oct 2026
  • disclosed21 Oct 2026

Introduced: 21 Oct 2026

NewCVE-2026-18495  (opens in a new tab)
CWE-122  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 libtiff5 to version 4.0.9-150000.45.72.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libtiff5 package and not the libtiff5 package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

A flaw was found in libtiff. A heap-buffer overflow vulnerability exists in the tiff2pdf utility due to an integer truncation error when processing crafted BigTIFF files. An attacker can provide a specially crafted BigTIFF file, causing a 64-bit StripByteCounts value to be truncated to a 32-bit integer. This leads to an undersized memory allocation and a subsequent out-of-bounds memory copy, resulting in a crash and severe memory corruption.

CVSS Base Scores

version 3.1