Uncontrolled Recursion Affecting liburiparser1 package, versions <0.8.5-150000.3.11.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.14% (4th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-LIBURIPARSER1-15268817
  • published12 Feb 2026
  • disclosed11 Feb 2026

Introduced: 11 Feb 2026

CVE-2025-67899  (opens in a new tab)
CWE-674  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 liburiparser1 to version 0.8.5-150000.3.11.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream liburiparser1 package and not the liburiparser1 package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

uriparser through 0.9.9 allows unbounded recursion and stack consumption, as demonstrated by ParseMustBeSegmentNzNc with large input containing many commas.

CVSS Base Scores

version 3.1