Numeric Truncation Error Affecting liburiparser1 package, versions <0.8.5-150000.3.14.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.17% (7th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-LIBURIPARSER1-17992552
  • published16 Jul 2026
  • disclosed15 Jul 2026

Introduced: 15 Jul 2026

CVE-2026-42371  (opens in a new tab)
CWE-197  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 liburiparser1 to version 0.8.5-150000.3.14.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream liburiparser1 package and not the liburiparser1 package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

uriparser before 1.0.1 has numeric truncation in text range comparison, if an application accepts URIs with a length in gigabytes.

CVSS Base Scores

version 3.1