Incomplete Blacklist Affecting libusbguard1 package, versions <1.1.2-150500.6.2.2


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.18% (7th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-LIBUSBGUARD1-20252701
  • published29 Sept 2026
  • disclosed28 Sept 2026

Introduced: 28 Sep 2026

CVE-2025-69277  (opens in a new tab)
CWE-184  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 libusbguard1 to version 1.1.2-150500.6.2.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libusbguard1 package and not the libusbguard1 package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

libsodium before ad3004e, in atypical use cases involving certain custom cryptography or untrusted data to crypto_core_ed25519_is_valid_point, mishandles checks for whether an elliptic curve point is valid because it sometimes allows points that aren't in the main cryptographic group.

CVSS Base Scores

version 3.1