Out-of-bounds Write Affecting nasm package, versions <2.16.03-150700.3.3.1


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.36% (30th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-NASM-18233705
  • published23 Jul 2026
  • disclosed22 Jul 2026

Introduced: 22 Jul 2026

CVE-2026-6067  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 nasm to version 2.16.03-150700.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nasm package and not the nasm package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

A heap buffer overflow vulnerability exists in the Netwide Assembler (NASM) due to a lack of bounds checking in the obj_directive() function. This vulnerability can be exploited by a user assembling a malicious .asm file, potentially leading to heap memory corruption, denial of service (crash), and arbitrary code execution.

CVSS Base Scores

version 3.1