Incorrect Authorization Affecting pam package, versions <1.3.0-150000.6.83.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
1.1% (66th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-PAM-10390228
  • published19 Jun 2025
  • disclosed18 Jun 2025

Introduced: 18 Jun 2025

CVE-2025-6018  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 pam to version 1.3.0-150000.6.83.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pam package and not the pam package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

A Local Privilege Escalation (LPE) vulnerability has been discovered in pam-config within Linux Pluggable Authentication Modules (PAM). This flaw allows an unprivileged local attacker (for example, a user logged in via SSH) to obtain the elevated privileges normally reserved for a physically present, "allow_active" user. The highest risk is that the attacker can then perform all allow_active yes Polkit actions, which are typically restricted to console users, potentially gaining unauthorized control over system configurations, services, or other sensitive operations.

CVSS Base Scores

version 3.1