Incorrect Privilege Assignment Affecting pam-himmelblau package, versions <0.7.17+git.0.1ebdab0-150700.3.3.2


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.2% (10th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-PAMHIMMELBLAU-10568361
  • published1 Jul 2025
  • disclosed30 Jun 2025

Introduced: 30 Jun 2025

CVE-2025-5791  (opens in a new tab)
CWE-266  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 pam-himmelblau to version 0.7.17+git.0.1ebdab0-150700.3.3.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pam-himmelblau package and not the pam-himmelblau package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

A flaw was found in the user's crate for Rust. This vulnerability allows privilege escalation via incorrect group listing when a user or process has fewer than exactly 1024 groups, leading to the erroneous inclusion of the root group in the access list.

CVSS Base Scores

version 3.1