CVE-2026-10879 Affecting perl-DBI package, versions <1.647.0-150600.12.11.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.49% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-PERLDBI-17816186
  • published4 Jul 2026
  • disclosed3 Jul 2026

Introduced: 3 Jul 2026

CVE-2026-10879  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 perl-DBI to version 1.647.0-150600.12.11.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream perl-DBI package and not the perl-DBI package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

DBI versions before 1.648 for Perl have a heap overflow when preparsing SQL statements with more than 9 binders.

The preparse method expands SQL placeholder characters to numbered binders of the form :pN, but only allocates three characters per binder in the buffer. Placeholders 10-99 require four characters, 100-999 require five characters, et cetera.

CVSS Base Scores

version 3.1