CVE-2026-57074 Affecting perl-XML-Bare package, versions <0.53-150000.3.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.63% (49th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-PERLXMLBARE-18468680
  • published30 Jul 2026
  • disclosed29 Jul 2026

Introduced: 29 Jul 2026

CVE-2026-57074  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 perl-XML-Bare to version 0.53-150000.3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream perl-XML-Bare package and not the perl-XML-Bare package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

XML::Bare versions through 0.53 for Perl have an unbounded character lookahead.

The parserc_parse function attempts to check for multicharacter strings such as "<![CDATA" or element terminators such as ">" without checking that the offsets are within the buffer.

Truncated strings such as "<a/" can trigger an out-of-bounds read.

CVSS Base Scores

version 3.1