Improper Input Validation Affecting python311-Authlib package, versions <1.3.1-150600.3.6.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.64% (49th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-PYTHON311AUTHLIB-13706432
  • published24 Oct 2025
  • disclosed23 Oct 2025

Introduced: 23 Oct 2025

CVE-2025-61920  (opens in a new tab)
CWE-20  (opens in a new tab)
CWE-400  (opens in a new tab)
CWE-770  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 python311-Authlib to version 1.3.1-150600.3.6.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python311-Authlib package and not the python311-Authlib package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to version 1.6.5, Authlib’s JOSE implementation accepts unbounded JWS/JWT header and signature segments. A remote attacker can craft a token whose base64url‑encoded header or signature spans hundreds of megabytes. During verification, Authlib decodes and parses the full input before it is rejected, driving CPU and memory consumption to hostile levels and enabling denial of service. Version 1.6.5 patches the issue. Some temporary workarounds are available. Enforce input size limits before handing tokens to Authlib and/or use application-level throttling to reduce amplification risk.

CVSS Base Scores

version 3.1