CVE-2026-33034 Affecting python311-Django package, versions <4.2.11-150600.3.56.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.77% (56th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-PYTHON311DJANGO-16538723
  • published8 May 2026
  • disclosed7 May 2026

Introduced: 7 May 2026

CVE-2026-33034  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 python311-Django to version 4.2.11-150600.3.56.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python311-Django package and not the python311-Django package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

An issue was discovered in 6.0 before 6.0.4, 5.2 before 5.2.13, and 4.2 before 4.2.30. ASGI requests with a missing or understated Content-Length header could bypass the DATA_UPLOAD_MAX_MEMORY_SIZE limit when reading HttpRequest.body, allowing remote attackers to load an unbounded request body into memory. Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected. Django would like to thank Superior for reporting this issue.

CVSS Base Scores

version 3.1