Expired Pointer Dereference Affecting python3-sssd-config package, versions <2.10.2-150700.9.37.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.12% (3rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-PYTHON3SSSDCONFIG-18468651
  • published30 Jul 2026
  • disclosed29 Jul 2026

Introduced: 29 Jul 2026

CVE-2026-12610  (opens in a new tab)
CWE-825  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 python3-sssd-config to version 2.10.2-150700.9.37.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python3-sssd-config package and not the python3-sssd-config package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

A flaw was found in sssd. When authenticating with a YubiKey, the SSSD PAM responder can crash due to a use-after-free vulnerability, where a memory pointer is incorrectly handled. A local attacker could exploit this flaw by manipulating smartcard or YubiKey contents, leading to a denial of service that disrupts authentication. This vulnerability also presents a potential for privilege escalation, although it is difficult to exploit.

CVSS Base Scores

version 3.1