CVE-2026-3195 Affecting qemu-hw-usb-smartcard package, versions <9.2.4-150700.3.20.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.17% (6th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-QEMUHWUSBSMARTCARD-17333178
  • published13 Jun 2026
  • disclosed12 Jun 2026

Introduced: 12 Jun 2026

CVE-2026-3195  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 qemu-hw-usb-smartcard to version 9.2.4-150700.3.20.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream qemu-hw-usb-smartcard package and not the qemu-hw-usb-smartcard package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

A flaw was found in QEMU. When reading input audio in the virtio-snd device input callback, the virtio_snd_pcm_in_cb function did not check whether the iov could fit the data buffer, potentially leading to a heap out-of-bounds write. This issue exists due to an incomplete fix for CVE-2024-7730.

CVSS Base Scores

version 3.1