Stack-based Buffer Overflow Affecting rrdtool-devel package, versions <1.8.0-150600.3.9.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.18% (7th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-RRDTOOLDEVEL-18518227
  • published4 Aug 2026
  • disclosed3 Aug 2026

Introduced: 3 Aug 2026

CVE-2026-43958  (opens in a new tab)
CWE-121  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 rrdtool-devel to version 1.8.0-150600.3.9.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rrdtool-devel package and not the rrdtool-devel package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

A flaw was found in rrdcached, a component of rrdtool. A local attacker with access to a rrdcached socket can exploit a stack-based buffer overflow by sending an oversized CREATE request. This vulnerability can lead to a denial of service by crashing the daemon or potentially allow for arbitrary code execution, impacting the integrity and confidentiality of data.

CVSS Base Scores

version 3.1