CVE-2025-7709 Affecting sqlite3-tcl package, versions <3.51.2-150000.3.36.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.37% (30th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-SQLITE3TCL-15272507
  • published12 Feb 2026
  • disclosed11 Feb 2026

Introduced: 11 Feb 2026

CVE-2025-7709  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 sqlite3-tcl to version 3.51.2-150000.3.36.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sqlite3-tcl package and not the sqlite3-tcl package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

An integer overflow exists in the FTS5 https://sqlite.org/fts5.html  extension. It occurs when the size of an array of tombstone pointers is calculated and truncated into a 32-bit integer. A pointer to partially controlled data can then be written out of bounds.

CVSS Base Scores

version 3.1