CVE-2025-6199 Affecting typelib-1_0-GdkPixbuf-2_0 package, versions <2.42.12-150600.3.8.1


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.21% (10th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-TYPELIB10GDKPIXBUF20-12150399
  • published22 Aug 2025
  • disclosed21 Aug 2025

Introduced: 21 Aug 2025

CVE-2025-6199  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 typelib-1_0-GdkPixbuf-2_0 to version 2.42.12-150600.3.8.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream typelib-1_0-GdkPixbuf-2_0 package and not the typelib-1_0-GdkPixbuf-2_0 package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

A flaw was found in the GIF parser of GdkPixbuf’s LZW decoder. When an invalid symbol is encountered during decompression, the decoder sets the reported output size to the full buffer length rather than the actual number of written bytes. This logic error results in uninitialized sections of the buffer being included in the output, potentially leaking arbitrary memory contents in the processed image.

CVSS Base Scores

version 3.1