Use After Free Affecting typelib-1_0-Poppler-0_18 package, versions <24.03.0-150600.3.16.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.45% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-TYPELIB10POPPLER018-10771439
  • published17 Jul 2025
  • disclosed16 Jul 2025

Introduced: 16 Jul 2025

CVE-2025-52886  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 typelib-1_0-Poppler-0_18 to version 24.03.0-150600.3.16.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream typelib-1_0-Poppler-0_18 package and not the typelib-1_0-Poppler-0_18 package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

Poppler is a PDF rendering library. Versions prior to 25.06.0 use std::atomic_int for reference counting. Because std::atomic_int is only 32 bits, it is possible to overflow the reference count and trigger a use-after-free. Version 25.06.0 patches the issue.

CVSS Base Scores

version 3.1