CVE-2026-64753 Affecting typelib-1_0-WebKit2WebExtension-4_0 package, versions <2.54.1-150600.12.81.4


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.37% (31st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-TYPELIB10WEBKIT2WEBEXTENSION40-21473004
  • published23 Oct 2026
  • disclosed22 Oct 2026

Introduced: 22 Oct 2026

NewCVE-2026-64753  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 typelib-1_0-WebKit2WebExtension-4_0 to version 2.54.1-150600.12.81.4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream typelib-1_0-WebKit2WebExtension-4_0 package and not the typelib-1_0-WebKit2WebExtension-4_0 package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

A permissions issue was addressed by removing the vulnerable code. This issue is fixed in Safari 27, iOS 27 and iPadOS 27, macOS Golden Gate 27, tvOS 27, visionOS 27, watchOS 27. Processing maliciously crafted web content may disclose sensitive user information.

CVSS Base Scores

version 3.1