CVE-2026-86898 Affecting webkit2gtk-4_1-injected-bundles package, versions <2.54.1-150600.12.81.3


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.35% (28th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-WEBKIT2GTK41INJECTEDBUNDLES-21475286
  • published23 Oct 2026
  • disclosed22 Oct 2026

Introduced: 22 Oct 2026

NewCVE-2026-86898  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 webkit2gtk-4_1-injected-bundles to version 2.54.1-150600.12.81.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream webkit2gtk-4_1-injected-bundles package and not the webkit2gtk-4_1-injected-bundles package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

A logic issue was addressed with improved state management. This issue is fixed in Safari 27, iOS 27 and iPadOS 27, macOS Golden Gate 27, visionOS 27. Opening a maliciously crafted webarchive file may lead to universal cross-site scripting.

CVSS Base Scores

version 3.1