CVE-2024-58249 Affecting wxWidgets-3_2-devel package, versions <3.1.5-150400.3.10.1


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.53% (44th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES157-WXWIDGETS32DEVEL-10266604
  • published30 May 2025
  • disclosed29 May 2025

Introduced: 29 May 2025

CVE-2024-58249  (opens in a new tab)

How to fix?

Upgrade SLES:15.7 wxWidgets-3_2-devel to version 3.1.5-150400.3.10.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream wxWidgets-3_2-devel package and not the wxWidgets-3_2-devel package as distributed by SLES. See How to fix? for SLES:15.7 relevant fixed versions and status.

In wxWidgets before 3.2.7, a crash can be triggered in wxWidgets apps when connections are refused in wxWebRequestCURL.

CVSS Base Scores

version 3.1