Reachable Assertion Affecting avahi-lang package, versions <0.8-160000.5.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.2% (11th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-AVAHILANG-17781500
  • published2 Jul 2026
  • disclosed22 Jun 2026

Introduced: 22 Jun 2026

CVE-2026-34933  (opens in a new tab)
CWE-617  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 avahi-lang to version 0.8-160000.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream avahi-lang package and not the avahi-lang package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

Avahi is a system which facilitates service discovery on a local network via the mDNS/DNS-SD protocol suite. Prior to version 0.9-rc4, any unprivileged local user can crash avahi-daemon by sending a single D-Bus method call with conflicting publish flags. This issue has been patched in version 0.9-rc4.

CVSS Base Scores

version 3.1