Out-of-Bounds Affecting bpftool-bash-completion package, versions <7.5.0-160000.2.3


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.59% (48th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-BPFTOOLBASHCOMPLETION-14425977
  • published16 Dec 2025
  • disclosed12 Dec 2025

Introduced: 12 Dec 2025

CVE-2025-1182  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 bpftool-bash-completion to version 7.5.0-160000.2.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream bpftool-bash-completion package and not the bpftool-bash-completion package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

A vulnerability, which was classified as critical, was found in GNU Binutils 2.43. Affected is the function bfd_elf_reloc_symbol_deleted_p of the file bfd/elflink.c of the component ld. The manipulation leads to memory corruption. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. The patch is identified as b425859021d17adf62f06fb904797cf8642986ad. It is recommended to apply a patch to fix this issue.

CVSS Base Scores

version 3.1