Heap-based Buffer Overflow Affecting cups package, versions <2.4.19-160000.1.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.41% (36th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-CUPS-17124560
  • published2 Jun 2026
  • disclosed26 May 2026

Introduced: 26 May 2026

CVE-2026-34979  (opens in a new tab)
CWE-122  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 cups to version 2.4.19-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cups package and not the cups package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. In versions 2.4.16 and prior, there is a heap-based buffer overflow in the CUPS scheduler when building filter option strings from job attribute. At time of publication, there are no publicly available patches.

CVSS Base Scores

version 3.1