Out-of-bounds Read Affecting cups-client package, versions <2.4.19-160000.1.1


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.41% (33rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-CUPSCLIENT-17124408
  • published2 Jun 2026
  • disclosed26 May 2026

Introduced: 26 May 2026

CVE-2026-41079  (opens in a new tab)
CWE-125  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 cups-client to version 2.4.19-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cups-client package and not the cups-client package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to 2.4.17, a network-adjacent attacker can send a crafted SNMP response to the CUPS SNMP backend that causes an out-of-bounds read of up to 176 bytes past a stack buffer. The leaked memory is converted from UTF-16 to UTF-8 and stored as printer supply description strings, which are subsequently visible to authenticated users via IPP Get-Printer-Attributes responses and the CUPS web interface. This vulnerability is fixed in 2.4.17.

CVSS Base Scores

version 3.1