Improper Authentication Affecting cups-devel package, versions <2.4.16-160000.1.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1% (63rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-CUPSDEVEL-15268449
  • published12 Feb 2026
  • disclosed4 Feb 2026

Introduced: 4 Feb 2026

CVE-2025-58060  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 cups-devel to version 2.4.16-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cups-devel package and not the cups-devel package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. In versions 2.4.12 and earlier, when the AuthType is set to anything but Basic, if the request contains an Authorization: Basic ... header, the password is not checked. This results in authentication bypass. Any configuration that allows an AuthType that is not Basic is affected. Version 2.4.13 fixes the issue.

CVSS Base Scores

version 3.1