CVE-2025-30187 Affecting dnsdist package, versions <1.9.11-160000.1.1


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.29% (21st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-DNSDIST-15997170
  • published12 Apr 2026
  • disclosed2 Apr 2026

Introduced: 2 Apr 2026

CVE-2025-30187  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 dnsdist to version 1.9.11-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream dnsdist package and not the dnsdist package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

In some circumstances, when DNSdist is configured to use the nghttp2 library to process incoming DNS over HTTPS queries, an attacker might be able to cause a denial of service by crafting a DoH exchange that triggers an unbounded I/O read loop, causing an unexpected consumption of CPU resources.

CVSS Base Scores

version 3.1