CVE-2026-33593 Affecting dnsdist package, versions <1.9.13-160000.1.1


Severity

Recommended
high

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.38% (32nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-DNSDIST-17781567
  • published2 Jul 2026
  • disclosed22 Jun 2026

Introduced: 22 Jun 2026

CVE-2026-33593  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 dnsdist to version 1.9.13-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream dnsdist package and not the dnsdist package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

A client can trigger a divide by zero error leading to crash by sending a crafted DNSCrypt query.